The object 'vim.cluster.VsanlscsiTargetSystem:vsan-iscsi-target-system' has already been deleted or has not been completely created".vSAN reports this issue when the vSAN iSCSI target service configuration file stored in the home object directory is not present or cannot be parsed."Check if vSAN iSCSI target service is enabled and all service daemons are running properly on all ESXi host through 'Service runtime status' healthCheck if the configure file exists from the directory /vmfs/volumes/vsanDatastore/.iSCSI-CONFIG/etc/vit.conf in all ESXi hosts.Check if there is any invalid characters in the configuration file /vmfs/volumes/vsanDatastore/.iSCSI-CONFIG/etc/vit.conf by comparing the back up file from/var/run/log/vit.conf.backup.vSAN Cluster > Configure > iSCSI Targets. Note down the I/O Owner Host name./var/log/vmware/vsan-health/vmware-vsan-health-service.log log file confirms that attempts to query the vSAN iSCSI Target Service configuration fail. YYYY-MM-DDTHH:MM.SSSZ ERROR vsan-mgmt[#####] [VsanVcIscsiTargetSystemImpl::EntityInHost opID=###-#######-####] Error query host ######## for operation GetIscsiTargetServiceConfigTraceback (most recent call last): File "bora/vsan/vit/vpxd/pyMoVsan/VsanVcIscsiTargetSystemImpl.py", line 693, in EntityInHost File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 601, in <lambda> File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 376, in _InvokeMethodPyCppVmomi.vmodl.fault.ManagedObjectNotFound: (vmodl.fault.ManagedObjectNotFound) { msg = 'Received SOAP response fault from [<<cs p:######, PIPE:/var/run/envoy-hgw/hgw-pipe>, /hgw/host-##/vsan>]: getIscsiTargetServiceConfig\n', obj = 'vim.cluster.VsanIscsiTargetSystem:vsan-iscsi-target-system'}YYYY-MM-DDTHH:MM.SSSZ ERROR vsan-mgmt[#####] [VsanVcIscsiTargetSystemImpl::_GetIscsiTargetServiceConfig opID=###-#######-####] Exception (vmodl.fault.ManagedObjectNotFound) { msg = 'Received SOAP response fault from [<<cs p:######, PIPE:/var/run/envoy-hgw/hgw-pipe>, /hgw/host-##/vsan>]: getIscsiTargetServiceConfig\n', obj = 'vim.cluster.VsanIscsiTargetSystem:vsan-iscsi-target-system'} occured when GetIscsiTargetServiceConfig in host, refer to cluster stateTraceback (most recent call last): File "bora/vsan/vit/vpxd/pyMoVsan/VsanVcIscsiTargetSystemImpl.py", line 1005, in _GetIscsiTargetServiceConfig File "bora/vsan/vit/vpxd/pyMoVsan/VsanVcIscsiTargetSystemImpl.py", line 854, in _QueryEntityInHost File "bora/vsan/vit/vpxd/pyMoVsan/VsanVcIscsiTargetSystemImpl.py", line 719, in EntityInHost File "bora/vsan/vit/vpxd/pyMoVsan/VsanVcIscsiTargetSystemImpl.py", line 693, in EntityInHost File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 601, in <lambda> File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 376, in _InvokeMethodPyCppVmomi.vmodl.fault.ManagedObjectNotFound: (vmodl.fault.ManagedObjectNotFound) { msg = 'Received SOAP response fault from [<<cs p:00007f1ee0833510, PIPE:/var/run/envoy-hgw/hgw-pipe>, /hgw/host-##/vsan>]: getIscsiTargetServiceConfig\n', obj = 'vim.cluster.VsanIscsiTargetSystem:vsan-iscsi-target-system'}vit.conf" file on all cluster nodes. On all or few hosts, accessing this file fails with a resource busy error:less /vmfs/volumes/vsanDatastore/.iSCSI-CONFIG/etc/vit.confvit.conf: Device or resource busyvmfsfilelockinfo -p "/vmfs/volumes/vsanDatastore/.iSCSI-CONFIG/etc/vit.conf"vmfsfilelockinfo Version 2.0Looking for lock owners on "vit.conf""vit.conf" is locked in Exclusive mode by host having mac address ['##:##:##:##:##:##']Trying to make use of Fault Domain ManagerFound 6 ESX hosts using Fault Domain Manager.Searching on Host Host - 1Searching on Host Host - 2MAC Address : ##:##:##:##:##:##'
Host owning the lock on file is Host - 2, lockMode : ExclusiveTotal time taken : 0.2545278499601409 seconds.
In this example, Host - 2 is holding the exclusive lock (But the current I/O Owner is HOST - 3)
Restart the "vitd" and "vsanmgmtd" services on the host (In this example, Host - 2) holding the stale lock.
/etc/init.d/vitd restart/etc/init.d/vsanmgmtd restart