Http failure response for https://<installer.example.com>/v1/sddcs/network-config-profiles: 504 OK

/var/log/vmware/vcf/domainmanager/domainmanager.logYYYY-MM-DDTHH:MM:SS.###+0000 DEBUG [vcf_dm, ####, ####] [c.v.evo.sddc.common.util.SshKeyScan, dm-exec-11] Getting SSH host key with algorithms rsa-sha2-512, rsa-sha2-256 from <ESX_Host>.example.com:22YYYY-MM-DDTHH:MM:SS.###+0000 WARN [vcf_dm, ####, ####] [c.v.evo.sddc.common.util.SshKeyScan, dm-exec-22] Fail to get host key for <ESX_Host>.example.com:22 with host key algorithms rsa-sha2-512, rsa-sha2-256YYYY-MM-DDTHH:MM:SS.###+0000 DEBUG [vcf_dm, ####, ####] [c.v.e.s.c.util.LocalProcessService, dm-exec-23] Error Output: ssh: connect to host <ESX_Host>.example.com port 22: Connection timed out
tcpdump port 22YYYY-MM-DD HH:MM:SS.### <VCF Installer IP> <ESX IP> TCP ## [TCP Retransmission] ##### → 22 [SYN] Seq=0 Win=#### Len=0 MSS=#### SACK_PERMThis issue is observed when SSH Connection over port 22 is blocked from VCF Installer to the ESX hosts by the external firewalls.
Allow Port 22 communication from VCF Installer appliance to the all the ESX hosts in external firewall.
Refer to VMware Ports and Protocols for more information on Port requirements.