Remediation of the ESXi password fails within VMware Cloud Foundation Operations (VCFOps). The targeted ESXi host displays a disconnected status in both VCF Ops and SDDC Manager.
When attempting to remediate the password from SDDC Manager, the following error message is presented:
Cause: Error in acquiring resource locks Lock for resource ESXI of type domain cannot be acquired by OPERATIONS_MANAGER service and #######-##95-45ee-##b4-7ce48ad#### task. Reason: Resource is already locked by OPERATIONS_MANAGER service and #####5-##6b-##f5-9aea- ######52be task
VMware Cloud Foundation Operations
VMware Cloud Foundation SDDC Manager
VMware vSphere ESXi
A stale exclusive resource lock in the SDDC Manager database and an out-of-band ESXi root password change prevents the OPERATIONS_MANAGER from synchronizing credentials, leading to account lockouts and disconnected state
psql -h localhost -U postgres -d platform -c "select id,resource_lock_type from lock;"psql -h localhost -U postgres -d platform -c "delete from lock where id='<####>';" cp /etc/security/opasswd /etc/security/opasswd.bak rm -f /etc/security/opasswd