エラーコード 502094 により、NSX ネイティブ ロードバランサー サービスと Tier-1 ゲートウェイ間の接続に失敗します。
search cancel

エラーコード 502094 により、NSX ネイティブ ロードバランサー サービスと Tier-1 ゲートウェイ間の接続に失敗します。

book

Article ID: 449665

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「Connection between the NSX Native load balancer service and the Tier-1 gateway fails with error code 502094.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • NSX Manager UI を介してロードバランサーサービスを Tier-1 ゲートウェイに接続しようとすると失敗します。

  • 対象の Tier-1 ゲートウェイの HA モードは「Distributed Only」に設定されています。

  • この問題が発生した際、NSX Manager 上の /var/log/proton/nsxapi.log に以下のエラーが記録されます。

    YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 ConnectivityValidationUtils 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM503099" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] Locale services need to be created for router /infra/tier-1s/{{TIER1_NAME}}, with edge clusters

    YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 LbServiceServiceImpl 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM502094" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] The tier-1 /infra/tier-1s/{{TIER1_NAME}} does not have associated edge cluster to deploy a load balancer service /infra/lb-services/{{LB_SERVICE_ID}}.

    YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 LbServiceServiceImpl 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM502001" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] Errors {"moduleName":"policy","errorCode":502094,"errorMessage":"The tier-1 /infra/tier-1s/{{TIER1_NAME}} does not have associated edge cluster to deploy a load balancer service /infra/lb-services/{{LB_SERVICE_ID}}."} validating LbService /infra/lb-services/{{LB_SERVICE_ID}}

Environment

VMware NSX

Cause

これは期待される動作です。
宛先のTier-1ゲートウェイは、アクティブ/スタンバイモードである必要があります。

Resolution

以下の手順に従って、Tier-1 ゲートウェイの HA モードを変更し、Edge クラスタを割り当てます。

  1. NSX Manager UI にログインします。
  2. [ネットワーク] > [Tier-1 ゲートウェイ] に移動します。
  3. ロードバランササービスをホストしている Tier-1 ゲートウェイを見つけ、縦の三点リーダー(︙)をクリックして [編集] を選択します。
  4. [HA モード] のドロップダウンメニューから「アクティブ/スタンバイ」を選択します。
  5. [Edge クラスタ] のドロップダウンメニューから、新しいターゲットの Edge クラスタを選択します。
  6. [Edge プール割り当てサイズ] が、デプロイ済みのロードバランサ(例:LB Small、LB Medium)に適したサイズに設定されていることを確認します。
  7. [保存] をクリックして設定を適用します。
  8. [ネットワーク] > [ロードバランシング] に移動します。
  9. ロードバランササービスを見つけ、縦の三点リーダー(︙)をクリックして [編集] を選択します。
  10. [アタッチメント] のドロップダウンメニューから、ロードバランササービスをホストしている Tier-1 ゲートウェイを選択します。
  11. [保存] をクリックして設定を適用します。

Additional Information