Ops Manager returns a 500 error page when updating LDAP settings while in rescue mode. This typically occurs when an operator attempts to update LDAP credentials.
The error being shown is:
500 An error occurred.
Contact VMware Technical Support to report the problem.
Back to dashboard
NoMethodError
undefined method 'encoded_token_string' for nil
/home/tempest-web/tempest/web/app/controllers/ldap_identity_providers_controller.rb:23:in 'LdapIdentityProvidersController#create'
... When the switch to Internal Authentication is attempted, a similar error is shown:
500 An error occurred.
Contact VMware Technical Support to report the problem.
Back to dashboard
NoMethodError
undefined method 'encoded_token_string' for nil
/home/tempest-web/tempest/web/app/controllers/internal_identity_providers_controller.rb:21:in 'InternalIdentityProvidersController#create'
...
VMware Tanzu Platform Core
Operations Manager
There seems to be a bug in the LdapIdentityProvidersController as it attempts to access a token object that is null when updating settings in rescue mode. There seems to be a change in UAA in Ops Manager v3.1.13 that likely introduced this issue.
This issue is resolved in Ops Manager versions 3.1.14 and later, as well as 3.3.5 and later.
If an immediate upgrade is not possible, apply the following temporary workaround:
/home/tempest-web/tempest/web/app/controllers/ldap_identity_providers_controller.rbencoded_token_string.&. to handle potential nil values. Change the line:sudo service tempest-web restart/home/tempest-web/tempest/web/app/controllers/ldap_identity_providers_controller.rbTo disable rescue mode:
1) Simply delete the rescue_mode file with sudo rm /var/tempest/workspaces/default/rescue_mode
2) Restart Ops Manager with sudo service tempest-web restart
Please ensure that you have exited Rescue Mode before running apply changes, otherwise you will receive an error.
https://knowledge.broadcom.com/external/article/293468/how-to-put-ops-manager-into-rescue-mode.html