When upgrading VMware NSX from version 3.# to 4.# in an environment where VMware Identity Manager (vIDM) is enabled, the following symptoms occur:
INFO http-nio-127.0.0.1-7442-exec-9 UpgradeServiceImpl SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="upgrade-coordinator"] Component type = MP, Upgrade Status = NOT_STARTED, Progress Percentage = 0, Progress Message = Running mandatory checks before upgrade
File: /var/log/proxy/reverse-proxy.log
ERROR https-jsse-nio-[NODE_IP]-443-exec-33 BaseProxyDelegate - [nsx@6876 comp="nsx-manager" errorCode="MP215" level="ERROR" subcomp="http"] Cannot make a query to server: http://##.##.##.##:7442/upgrade-coordinator/api/v1/upgrade/plan?action=upgrade&component_type=MP
org.apache.http.NoHttpResponseException: ##.##.##.##:7442 failed to respond
VMware NSX
During the initialization phase, the Upgrade Coordinator (UC) invokes the repo-sync API on a Manager node. A known issue in the proxy service causes it to hang indefinitely while waiting for a response from vIDM. Because the proxy service is stuck, the UC initialization process cannot complete, leading to a hang and a blank UI.
Permanent Fix: This issue is resolved in VMware NSX 4.2.3. It is recommended to plan an upgrade to this version or later to avoid this bug.
Workaround: If you encounter this issue during an active upgrade:
> restart service proxy