ESXi host profile compliance checks fail and return an out-of-compliance status after changing the syslog.global.auditRecord.storageDirectory value to persistent storage.
The setting syslog.global.auditRecord.storageDirectory is not visible within the host profile editor, preventing administrators from modifying or removing the setting.
VMware vSphere ESXi 8.0 U3
The host profile engine attempts to apply the advanced configuration but encounters a conflict because the audit record storage cannot be modified while it is enabled or actively in use.
Add the missing settings Syslog.global.auditRecord.storageDirectory and syslog.global.auditRecord.storageCapacity to the host profile configuration.
Uncheck both settings to remove them from compliance enforcement.
If errors occur when attempting to add or modify either of those parameters, add the Syslog.global.auditRecord.storageEnable setting to the profile and configure it to the default value (False).
Save the host profile.
Execute host profile remediation to confirm the ESXi host evaluates as compliant.