IS ASM Monitoring station - phase 2 fails on
search cancel

IS ASM Monitoring station - phase 2 fails on

book

Article ID: 449439

calendar_today

Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

Container fails to start.

✘ cbot cannot scale, replicas can only be 0 or 1
 
[ASM] Installation failed. Container idling for debugging (docker exec asm-monitoring-station bash).

I could not find any Docker desktop or Docker compose changes that appear to resolved this

docker compose config

name: asm-monitoring-station
services:
  asm-monitoring-station:
    build:
      context: <directory>
      dockerfile: Dockerfile
    cap_add:
      - NET_ADMIN
      - NET_RAW
    container_name: asm-monitoring-station
    deploy:
      mode: replicated
      replicas: 1
    environment:
      ASM_ENGINE: docker
      ASM_INSTALL_TOKEN: <token>
      TZ: UTC
    hostname: asm-monitoring-station
    image: asm-monitoring-station:latest
    networks:
      asm-net: null
    ports:
      - mode: ingress
        target: 80
        published: "80"
        protocol: tcp
      - mode: ingress
        target: 443
        published: "443"
        protocol: tcp
    privileged: true
    restart: on-failure
    volumes:
      - type: bind
        source: <source>
        target: /var/lib/asm
        bind: {}
      - type: bind
        source: /var/run/docker.sock
        target: /var/run/docker.sock
        bind: {}
networks:
  asm-net:
    name: asm-monitoring-station_asm-net
    driver: bridge

Resolution

Cbot is an obsolete agent and cannot scale. The new ccagent, a drop-in replacement, can scale both vertically and horizontally. The new installer does not install the old cbot any more