VCF Error: "Configure vSAN Stretch Cluster" during vSAN Stretched Cluster Configuration
search cancel

VCF Error: "Configure vSAN Stretch Cluster" during vSAN Stretched Cluster Configuration

book

Article ID: 449408

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • Greenfield deployment of a VCF Management Domain encounters an issue while configuring the stretched cluster. 
  • Failure occurrs on step Remediate Hosts (LCM)
  • vSAN witness shows as partitioned from the data nodes.
  • The deployment fails during the "Configure vSAN Stretch Cluster" step with the following error messages: 
    Message: Failed to configure fault domains on cluster #####-####
    Remediation Message:
    Reference Token: TAME3F
    Cause: com.vmware.evo.sddc.common.client.vmware.vsphere.VsphereOperationException:
    Task: (MOR:task-5040) (Name:unknown)
    Entity: (MOR:domain-##) (Name:#####-####) is failed
    Task: (MOR:task-5040) (Name:unknown)
    Entity: (MOR:domain-##) (Name:#####-####) is failed
    Cannot complete the operation. See the event log for details.
  • /var/log/vmware/vlcm/vlcm.log 
    INFO vmware-vum-server 9589 [vc@####sub="EHP" opID="########-####-####-####-############"] Entity [host-####] health status for perspective [FINALIZE] is: NOT_OK for service(s) [vSAN]
    ...
    INFO vmware-vum-server 3384285 [vc@####sub="RemediateClusterTask" opID="########-####-####-####-############"] [ApplyHelpers 577] CheckHostHealth - check - issues size = 1 - status = 3 - check = com.vmware.vcIntegrity.lifecycle.health.vsan.cluster_initialization name = Can vSAN cluster receive a host - description = Checks the vSAN cluster if a host can be added.

Environment

VMware SDDC Manager / VCF Installer 9.1.0.0100

Cause

  • Network configuration, witness host is not able to connect to the other data hosts in the cluster

Resolution

  1. Network ports need to be open correctly on the Firewall. Please refer to VMware Ports and Protocols
  2. Network partition needs to be solved