When attempting to configure or re-enable vSphere High Availability (HA) on an ESXi host within a Supervisor cluster, the task fails with a specific configuration error.
Symptoms:
HA - There was an error unconfiguring the vSphere HA agent on this host. To solve this problem, reconnect the host to vCenter Server.fdm.log) stop recording new entries.The vSphere HA agent (FDM) installation is blocked because the host management agents are deadlocked. This deadlock is caused by a hung Spherelet process or a vSphere Kubernetes Service (VKS) task that is stuck in a transient configuration state. While these services are unresponsive, the host cannot process the VIB installation required for HA.
To resolve this, the host management services must be cleared via a reboot. Follow these steps:
Connected and the Supervisor cluster status returns to Healthy.