During the brownfield converge process to VMware Cloud Foundation (VCF) 9.1, the precheck fails at the Security Configuration validation step for the NSX Manager.
The VCF Installer UI displays the following error message for the NSX Manager validation :
The administrator credentials for NSX <NSX Manager FQDN> are not correctly specified.Remediation : Verify that correct administrator credentials are specified and the account is not locked.
The following errors can be found in the /var/log/vmware/vcf/domainmanager/domainmanager.log on the VCF Installer appliance:
domainmanager.logYYYY-MM-DDThh:mm:ss.nnn+0000 ERROR [vcf_dm,xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx,xxxx] [c.v.v.c.n.s.c.c.NsxtConnectionFactory,dm-exec-xxxx] Unable to connect to admin@<NSX Manager FQDN>com.vmware.vapi.std.errors.Unauthorized: Unauthorized (com.vmware.vapi.std.errors.unauthorized) (statusCode:403) => { messages = [], data = => {error_message=The credentials were incorrect or the account specified has been locked., error_code=403, module_name=common-services}, errorType = UNAUTHORIZED, challenge = <null>}
VMware Cloud Foundation 9.1
VMware NSX 4.x
This issue could occur if the default local user named admin does not exist on the NSX Manager.
The VCF installer uses the default admin username to connect and authenticate with the NSX Manager during the converge process.
If the default admin user does not exist, the authentication fails with a 403 Unauthorized error.
To resolve this issue, the NSX default local user, named admin must exist before proceeding with the VCF converge process.
If you renamed the admin user to another name, please refer to KB 416999 for instructions on how to rename the local user account back to admin.
Once the admin user is available, retry the VCF converge precheck from the VCF Installer UI.