VMware vCenter Server 8.x
This issue occurs because the VMware Directory Service operating state has been set to READ_ONLY (State 2).
By design, when vmdir is in a read-only state, any modification operations is rejected.
To restore full write permission to vmdir, set the state to "Normal" using vdcadmintool: