Deleting or Reconfiguring LDAPS Identity Source Fails with "Unexpected error encountered while removing selected identity source"
search cancel

Deleting or Reconfiguring LDAPS Identity Source Fails with "Unexpected error encountered while removing selected identity source"

book

Article ID: 449333

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to delete, reconfigure, or add an LDAPS identity source in vCenter Server using the [email protected] account, the task fails with the following user interface error: "Unexpected error encountered while removing selected identity source."
  •  In less /var/log/vmware/vmdird/vmdird.log shows LDAP operations failing with following error: 
    • YYYY-MM-DDTHH:MM:SSZ:t@1399XXXX:ERROR: VmDirSendLdapResult: Request (Modify), Error (LDAP_UNWILLING_TO_PERFORM(53)), Message (Server in read-only mode), (0) socket (127.0.0.1)
  • vmdir state is Read only, when running the below command: /usr/lib/vmware-vmdir/bin/dir-cli state get

Environment

VMware vCenter Server 8.x

Cause

This issue occurs because the VMware Directory Service operating state has been set to READ_ONLY (State 2).

By design, when vmdir is in a read-only state, any modification operations is rejected.

Resolution

To restore full write permission to vmdir, set the state to "Normal" using vdcadmintool:

  • Login to VCSA via SSH using root credentials.
  • Run the vdcadmintool:
    • /usr/lib/vmware-vmdir/bin/vdcadmintool
  • Change vmdir state to Normal:
    • Select Option 5 and select Normal
  • Verify if the state has been updated to Normal using command: /usr/lib/vmware-vmdir/bin/dir-cli state get