After upgrading to vCenter 8.x, you see frequent tasks related to Cloud Native Storage (CNS) fail with the error: Sync Volume error
vpxd.log:
####-##-##T##:##:##.564Z error vpxd[26341] [Originator@6876 sub=Default opID=1d755ca6-2f] [VpxLRO] -- ERROR lro-139956 -- ####-####-####-####-####(uuid) -- VStorageObjectManager -- vim.vslm.vcenter.VStorageObjectManager.retrieveVStorageObjectMetadata: :vmodl.fault.SystemError
--> Result:
--> (vmodl.fault.SystemError) {
--> faultCause = (vmodl.MethodFault) null,
--> faultMessage = <unset>,
--> reason = "Failed to lock the file: api = DiskLib_Open, _diskPath->CValue() = /vmfs/volumes/##/fcd/##/####.vmdk"
--> msg = "Received SOAP response fault from [<<io_obj p:0x00007f900c7259a8, h:74, <UNIX ''>, <UNIX '/var/run/envoy-hgw/hgw-pipe'>>, /hgw/host-####/vpxa>]: retrieveVStorageObjectMetadataVcenter 8.0.1, 8.x
ESXi 8.0.1
TCP 5.0.1
After upgrading to vCenter 8.x, CNS runs a full sync on datastores to clean up
To resolve the issue:
""file:" then please refer below to resolve:-> msg = "Received SOAP response fault from [<<io_obj p:0x00007f900c7259a8, h:74, <UNIX ''>, <UNIX '/var/run/envoy-hgw/hgw-pipe'>>, /hgw/host-####/vpxa>]: retrieveVStorageObjectMetadata"host-####" which may be having some stale lock file."host-XXX" ; then go back to Vcenter UI and select each host and refer URL section that matches with the host reported in the logs.