Clone operations fail with timeout errors on specific VMs
search cancel

Clone operations fail with timeout errors on specific VMs

book

Article ID: 449249

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Cloning files with timeout errors on specific VM(s) with error similar to:

2026-06-10T17:24:39.689Z error vpxd[06757] [Originator@6876 sub=VmProv opID=mpzrxaxx-xxxxx-auto-xxxx-h5:xxxx7085-75-01] Local-VC Datastore Full Clone failed at vpx.vmprov.CopyVmFiles for poweredOff VM '<vm_name>' (vm-xxxx, ds:///vmfs/volumes/5xxxxxxx-xxxxxxxx-xxxx-xxxxxxxxxxxx/<directory>/<vm_name>.vmx) to new name <clone_name> on host-xxxx (host_ip) in pool resgroup-xxx39 with ds ds:///vmfs/volumes/xxxxxxxx-xxxxxxxxx-xxxx-xxxxxxxxxxxxx/ to host-xxxx (<host_ip>) in pool resgroup-xxxxxx with ds ds:///vmfs/volumes/5xxxxxxx-xxxxxxxx-xxxx-xxxxxxxxxxxx/ with fault vim.fault.Timedout:

 

Environment

vSphere 8.x

vSphere 9.x

While often manifests in VDI environments, this issue can occur in purely vSphere cloning operations.

Cause

Long snapshot chains on the VMs in question can cause degradation on write speed on the virtual disks of the VMs in question.

Resolution

Delete the snapshots on the VMs as soon as possible.