Service Fails to Start in Log Management Configured with External Storage
search cancel

Service Fails to Start in Log Management Configured with External Storage

book

Article ID: 449139

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

The service fails to start in Log Management when configured with external storage.

 
# k get pod -n ops-logs log-processor-0 log-store-0
NAME              READY   STATUS              RESTARTS   AGE
log-processor-0   0/2     ContainerCreating   0          4d21h
log-store-0       0/1     Init:0/2            0          4d21h
#

Environment

VCF Operations 9.1.0

 

Cause

This issue occurs because the node cannot access the NFS server configured as external storage.

kubelet[####]: Mounting arguments: -t nfs ##NFS_SERVER_IP##:/##MOUNT_POINT## /var/lib/kubelet/pods/##UUID##/volumes/kubernetes.io~nfs/##UUID##
kubelet[####]: Output: mount.nfs: access denied by server while mounting ##NFS_SERVER_IP##:/##MOUNT_POINT##

Resolution

Modify the NFS server configuration so that the node running the Log Management service can correctly mount the NFS share.

Additional Information

Japanese version: 外部ストレージを設定している Log Management にてサービスが起動できない。