免責事項: これは英文の記事「Service Fails to Start in Log Management Configured with External Storage」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
外部ストレージを設定している Log Management にてサービスが起動できない。
# k get pod -n ops-logs log-processor-0 log-store-0
NAME READY STATUS RESTARTS AGE
log-processor-0 0/2 ContainerCreating 0 4d21h
log-store-0 0/1 Init:0/2 0 4d21h
#
VCF Operations 9.1.0
外部ストレージとして設定した NFS サーバ へのアクセスが出来ないことが原因です。
kubelet[####]: Mounting arguments: -t nfs ##NFS_SERVER_IP##:/##MOUNT_POINT## /var/lib/kubelet/pods/##UUID##/volumes/kubernetes.io~nfs/##UUID##
kubelet[####]: Output: mount.nfs: access denied by server while mounting ##NFS_SERVER_IP##:/##MOUNT_POINT##
Log Management サービスが動作するノードで正しく NFS マウントできるように NFS サーバの設定を変更をしてください。