"500 ERROR. Internal Server Error!" when logging into VCF Operations using vCenter SSO SAML with Active Directory
search cancel

"500 ERROR. Internal Server Error!" when logging into VCF Operations using vCenter SSO SAML with Active Directory

book

Article ID: 449119

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • You have joined Active Directory (AD) to vCenter using LDAP.

  • You have configured vCenter as an authentication source in VCF Operations using "SSO SAML".

  • When attempting to log in to Ops using the SSO SAML authentication source, with the “Automatically redirect VCF Operations single sign-on URL” option disabled, the login results in an indefinite loading spinner and with the error “Single Sign-On Redirect URL is Null.”

  • With the “Automatically redirect VCF Operations single sign-on URL” option enabled, the login fails with "500 ERROR: Internal server error!"

Environment

VCF Operations 9.x

Cause

SSO SAML authentication is currently broken and does not function correctly in VCF Operations 9.0.x and the base 9.1 release.

Resolution

Resolution:

This is a known issue. To resolve this, upgrade VCF Operations to version 9.1 EP2 which includes the fix for this issue.

Workaround:

If an upgrade to 9.1 EP2 is not feasible, it is highly recommended to migrate the authentication mechanism from SSO SAML to vIDB SSO.

vIDB SSO is the modern, most efficient solution for SSO in VCF. For instructions on configuring vIDB, please refer to the official documentation: Setting Up SSO.

Additional Information