免責事項: これは英文の記事 「Unpredictable error observed on Syslog server during log forwarding from vCenter Server」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
MM DD HH:MM:SS #### syslog.err: rsyslogd error during parsing file /etc/vmware-syslog/vmware-services-vlcm.conf, on or before line 8: parameter 'reopenontruncate' must be "on" or "off" but is neither. Results unpredictable. [v8.2306.0 try https://www.rsyslog.com/e/2207 ]
MM DD HH:MM:SS #### syslog.err: rsyslogd error during parsing file /etc/vmware-syslog/vmware-services-vlcm.conf, on or before line 8: parameter 'deletestateonfiledelete' must be "on" or "off" but is neither. Results unpredictable. [v8.2306.0 try https://www.rsyslog.com/e/2207]
reopenOnTruncate パラメータの設定は無視されますが、rsyslog サービス自体は動作を継続し、設定されている他のオプションに従ってログを転送します。/etc/vmware-syslog/vmware-services-vlcm.conf ファイル内で、 deleteStateOnFileDelete および reopenOnTruncate パラメータが "true" に設定されています。VMware vCenter 9.x
この問題は、vCenter Server 上の cron ジョブにより deleteStateOnFileDelete および reopenOnTruncate パラメータが意図せず "true" に設定されることで発生します。
rsyslog サービスは "on" または "off" の値のみをサポートしています。
この問題は将来の製品リリースで修正される予定です。
回避策
cp /etc/vmware-syslog/vmware-services-vlcm.conf /etc/vmware-syslog/vmware-services-vlcm.conf_bkcp /usr/lib/applmgmt/support/space_utility/datastructures.py /usr/lib/applmgmt/support/space_utility/datastructures.py_bk/usr/lib/applmgmt/support/space_utility/datastructures.py ファイルを以下のように修正します:変更前:
def flags_to_check(self):
"""Returns the im module definition's mandatory flags
and its expected flag values
"""
return {
'deleteStateOnFileDelete': {'"on"', '"true"'},
'reopenOnTruncate': {'"on"', '"true"'},
}
変更後 :
def flags_to_check(self):
"""Returns the im module definition's mandatory flags
and its expected flag values
"""
return {
'deleteStateOnFileDelete': {'"on"'},
'reopenOnTruncate': {'"on"'},
}
注意: 行頭のインデント (半角スペースによる字下げ) が正しく挿入されていることに注意し、引用符はすべて半角のクォーテーション(" または ')を使用してください。
"on" に更新され、問題が解消することを確認します。