Services failing to start due to GC overhead error in catalina log.
search cancel

Services failing to start due to GC overhead error in catalina log.

book

Article ID: 448985

calendar_today

Updated On:

Products

Network Observability VMware Smart Assurance

Issue/Introduction

Newly installed NCM server services fails to start, error noticed in catalina,out "java.lang.OutOfMemoryError: GC overhead limit exceeded error", caused by point to missing of required library. 

Error observed in catalina in addition to GC overhead is "Required classpath file '$VOYENCE_HOME/webtomcat/webapps/ncm/WEB-INF/lib/ncm-sso-client-<NCMVersion>.jar'" does not exist.

Environment

All supported NCM versions.

Cause

Number of JAR files available in '$VOYENCE_HOME/webtomcat/webapps/ncm/WEB-INF/lib/' is less compared to working environment.

Resolution

  1. Zip library directory from $VOYENCE_HOME/webtomcat/webapps/ncm/WEB-INF from working server running same version and copy to non-working server.
  2. Unzip it, changed ownership to ncm:voyence to copied files. 
  3. Modify webswing.config located in $VOYENCE_HOME/webtomcat/webswing to point to correct server/IP address.
  4. Modify webswing-admin.properties and webswing.properties located in $VOYENCE_HOME/webtomcat/bin to point to correct server/IP address.