Edge Gateway deletion fails in VCD Provider Portal with error code 500030
search cancel

Edge Gateway deletion fails in VCD Provider Portal with error code 500030

book

Article ID: 448958

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Deleting the Edge Gateway fails with the following error:
Bad Request: Error occurred in the backing network provider: The object path=[/infra/tier-##/########-####-####-####-############] cannot be deleted as either it has children or it is being referenced by other objects path=[/infra/segments/########-####-####-####-############], error code 500030
  • There are no OVDC Networks link to the Edge Gateway.

Environment

VMware Cloud Ditector 10.6.x

Cause

A segment corresponding to the OVDC network deleted in VCD still exists in NSX.

Normally, when an OVDC network connected to an Edge Gateway is deleted in VCD, the corresponding segment is also deleted from NSX.

If an inconsistency occurs where a segment remains even though the OVDC network was deleted, the Edge Gateway continues to reference the segment, causing the deletion of the Edge Gateway to fail.

Resolution

Deleting the corresponding segment in NSX and then deleting the Edge Gateway in VCD.

  1. Delete Segment: 
    NSX UI -> Networking -> Connectivity -> Segments -> Click ellipsis menu of corresponding segment -> Delete

  2. Delete Edge Gateway: 
    VCD Provider Portal -> Cloud Resources -> Edge Gateway -> Select the target Edge Gateway -> DELETE

Additional Information

Japanese Version:
VCD プロバイダポータルでの Edge Gateway の削除が error code 500030 で失敗する