NSX Edge deployment fails with the error: 'This feature is not supported with the current applied license'
search cancel

NSX Edge deployment fails with the error: 'This feature is not supported with the current applied license'

book

Article ID: 448957

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to deploy an Edge node from the NSX Manager UI, the deployment fails and outputs the following error at the end:
    This feature is not supported with the current applied license. Please upgrade your license in order to use this feature.

  • After manually deploying an NSX Edge using an OVA file or installing a bare-metal Edge, executing the join command outputs the following error:
    nsx_edge> join management-plane <NSX_Manager_IP> username admin password <Password> thumbprint <Thumbprint>
    % Node registration failed: 'This feature is not supported with the current applied license. Please upgrade your license in order to use this feature.'
  • The results of the GET /api/v1/licenses/licensed-features API indicate that the EDGE_NODE feature is not in a licensed state:
      }, {
        "feature_name" : "EDGE_NODE",
        "is_licensed" : false
      }, {

Environment

VMware NSX

Cause

A license that enables the EDGE_NODE feature has not been applied to the environment.

Resolution

Apply a valid license that supports the EDGE_NODE feature.