Aria Operations for Logs の SMTP サーバー設定時に「テスト メールの送信に失敗しました...」が表示される
search cancel

Aria Operations for Logs の SMTP サーバー設定時に「テスト メールの送信に失敗しました...」が表示される

book

Article ID: 448928

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

免責事項: これは英文の記事「Error: "Failed to send test email..." while configuring SMTP server for Aria Operations for Logs」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • SMTP サーバーの設定中にエラーメッセージが表示される:

    [テスト メールの送信に失敗しました] org.apache.commons.mail.EmailException: Sending the email to the following server failed

  • Operations for Logs ノードから SMTP サーバーへの Telnet 接続が、確立直後に切断される。
  • ログファイル /var/log/loginsight/runtime.log に以下が含まれる:

    Caused by: javax.mail.MessagingException: Could not connect to SMTP host: [IP_ADDRESS] port: 25, response: -1

Environment

VMware Aria Operations for Logs 8.18.x

 

Cause

SMTP サーバーが許可されていないリレーを拒否するように設定されています。これは、Aria Operations for Logs アプライアンスの IP アドレスが、SMTP サーバーの信頼済み IP リストまたは「許可」リレーリストに含まれていない場合に発生します。

 

Resolution

この問題を解決するには、SMTP サーバー側で Aria Operations for Logs アプライアンスの IP がリレー用にホワイトリスト登録されていることを確認してください。

この作業を行うには、SMTP サーバーの管理者またはベンダーに支援を依頼してください。    

SMTP サーバー側で Aria Operations for Logs の IP をホワイトリストに登録した後、SMTP 接続をテストします。

手順例は以下の通りです:

  1. Aria Operations for Logs クラスタ内のすべてのノードの IP アドレスが SMTP サーバーによって信頼されていることを確認します。
  2. Aria Operations for Logs の CLI から接続をテストし、接続がすぐに切断されないことを確認します:

    curl -v telnet://[IP_ADDRESS]:25

  3. Aria Operations for Logs の UI で、再度 SMTP サーバーの設定を試みます。

Additional Information

VMware Aria Operations for Logsの SMTP サーバの構成

 

English version: Error: "Failed to send test email..." while configuring SMTP server for Aria Operations for Logs