When attempting to deploy the identity broker (vIDB) via fleet manager on VMware Cloud Foundation (VCF) in a dark site (air-gapped) environment, the deployment fails during the "Deploying infrastructure components" phase. The deployment fails with an INIT0003 error, specifically returning the following message:INIT0003 error, specifically stating: ERROR: failed to create cluster: failed to pull image "registry.vmsp-platform.svc.cluster.local:5000/images/kindest-node:v1.32.8": command "docker pull registry.vmsp-platform.svc.cluster.local:5000/images/kindest-node:v1.32.8" failed with error: exit status 1
An incorrect or newer version of the vIDB binary is side-loaded onto the Fleet Management appliance. In air-gapped environments requiring manual staging, an incompatible binary prevents the system from extracting the required OCI components and manifests, resulting in a manifest unknown error.
Access the fleet appliance and check the file currently copied to the '/data/PROD/COMP/VIDB' folder.
Identify the file that is present (vidb-external-9.0.2.0.25084325.tar).
Re -download the correct version (9.0.2.0) and copy it to the '/data/PROD/COMP/VIDB' directory on the fleet appliance.
Confirm the integrity of the file by running the following command:
sha256sum vidb-external-9.0.2.0.25084325.tar