In vSphere with Tanzu environments, PersistentVolumeClaim (PVC) resize operations fail due to a service account lockout. This condition occurs when the Supervisor CSI controller is unable to authenticate with vCenter Server.
Symptoms:
err=ServerFaultCode: Cannot complete login due to an incorrect user name or password.vmdird.log contains lockout events for the storage service principal associated with the supervisor: WARNING: LoginBlocked DN (cn=wcp-storage-user-...), error (9241)(Account access blocked).websso.log and vmware-identity-sts-default.logcontain envoy overloaded errors./usr/lib/vmware-vmafd/bin/dir-cli user find-by-name --account wcp-storage-user-#######-####-####-####-########-########-####-####-####-######## --level 2
Enter password for [email protected]:
Account: wcp-storage-user-#######-####-####-####-########-########-####-####-####-########
UPN: wcp-storage-user-#######-####-####-####-########-########-####-####-####-########@VSPHERE.LOCAL
Account disabled: FALSE
Account locked: TRUE
Password never expires: FALSE
Password expired: FALSE
Password expiry: 89 day(s) 23 hour(s) 53 minute(s) 33 second(s)
Product: VMware Cloud Foundation / vSphere with Tanzu
Component: Supervisor Cluster, CSI Driver, VMware vSphere Kubernetes Service (VKS)
Version: vCenter Server 8.0 Update 3g (build 24155106) and earlier
Envoy-sidecar heap memory exhaustion prevents wcpsvc from rotating the wcp-storage-user password every 12 hours.
This leads to account lockouts and CSI operation failures.
Fixed in release vCenter Server 8.0 U3h and higher. See Download Broadcom products, patches and software for steps to download this release.
envoy-sidecar heap memory per .service-control --stop wcpkubectl get deployment vsphere-csi-controller -n vmware-system-csikubectl scale deployment vsphere-csi-controller -n vmware-system-csi --replicas=0/opt/likewise/bin/ldapmodify -x -D cn=Administrator,cn=Users,dc=vsphere,dc=local -W <<EOFdn: cn=wcp-storage-user-#######-####-####-####-########-########-####-####-####-########,cn=serviceprincipals,dc=vsphere,dc=localchangetype: modifyreplace: userAccountControluserAccountControl: 0EOF
/usr/lib/vmware-vmafd/bin/dir-cli user find-by-name --account wcp-storage-user-#######-####-####-####-########-########-####-####-####-######## --level 2The output will show the account locked value is FALSEEnter password for [email protected]:
Account: wcp-storage-user-#######-####-####-####-########-########-####-####-####-########
UPN: wcp-storage-user-#######-####-####-####-########-########-####-####-####-########@VSPHERE.LOCAL
Account disabled: FALSE
Account locked: FALSE
Password never expires: FALSE
Password expired: FALSE
Password expiry: 89 day(s) 23 hour(s) 53 minute(s) 33 second(s)
service-control --start wcpkubectl scale deployment vsphere-csi-controller -n vmware-system-csi --replicas=03