After upgrading a VMware Cloud Foundation (VCF) environment from version 9.0.2 to 9.1, administrators may encounter the following issues when managing Tenant regions:
column catalog_item.entity_id does not existWhere: PL/pgSQL function getapptemplatestatus(uuid) line 7 at SQL statementvCF Automation 9.1
This issue is caused by stale or orphaned entries remaining in the Tenant Manager database following an upgrade or failed Supervisor redeployment. The schema validation fails because the catalog_item table contains metadata that the getapptemplatestatus function cannot process.
A resolution is planned for the issue in the 9.1.2 & 9.2.0 vCF Automation product versions.
To resolve the issue on lower versions contact Broadcom Support and reference Knowledge Article ID 448740 in the problem description. For more information, see How to Submit a Support Request.