Unable to delete RegionQuota in VCF 9.1: PostgreSQL error "column catalog_item.entity_id does not exist"
search cancel

Unable to delete RegionQuota in VCF 9.1: PostgreSQL error "column catalog_item.entity_id does not exist"

book

Article ID: 448740

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

After upgrading a VMware Cloud Foundation (VCF) environment from version 9.0.2 to 9.1, administrators may encounter the following issues when managing Tenant regions:

  • Attempting to delete a RegionQuota from the Tenant Management (TM) UI fails.
  • The UI displays a PostgreSQL-related error:

    • column catalog_item.entity_id does not exist
    • Where: PL/pgSQL function getapptemplatestatus(uuid) line 7 at SQL statement
  • Subsequent attempts to re-configure a Supervisor with an old region result in a greyed-out "Submit" button.

Environment

vCF Automation 9.1

Cause

This issue is caused by stale or orphaned entries remaining in the Tenant Manager database following an upgrade or failed Supervisor redeployment. The schema validation fails because the catalog_item table contains metadata that the getapptemplatestatus function cannot process.

Resolution

A resolution is planned for the issue in the 9.1.2 & 9.2.0 vCF Automation product versions.

To resolve the issue on lower versions contact Broadcom Support and reference Knowledge Article ID 448740 in the problem description. For more information, see How to Submit a Support Request.