VCF installer General Information page - DNS servers field shows error of “Provided addresses must be at least one of #.#.#.#"
search cancel

VCF installer General Information page - DNS servers field shows error of “Provided addresses must be at least one of #.#.#.#"

book

Article ID: 448712

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

When attempting to deploy new VCF 9.1 instance to existing VCF 9.1 environment the VCF installer “General Information” page is not allowing the use of any other DNS servers than the ones previously configured at initial deployment.

Environment

VCF 9.1

Cause

The desired DNS servers are not listed in the VCF Installer’s “resolve.conf” configuration file.

  • The error "Provided addresses must be at least one of " typically occurs when the VCF 9.1 Installer UI enforces a strict validation that the new DNS servers must include at least one entry from the current appliance's configuration.

Resolution

  1. Follow steps from KB VCF Installer Validate & Deploy - DNS Error for 127.0.0.1 to confirm DNS resolution for each DNS server being added.

  2. Follow steps from KB Deployment of VCF 9.1 fails on Generate VCF Domain workflow Input data to update the VCF Installer (SDDC Manager) “resolve.conf” file with the additional DNS servers. Make sure to add them as comma separate with NO spaces between them. At this time we are not aware of a limit to the number of DNS servers allowed to be set in the config file.

  3. Attempt deployment again using the desired DNS servers specific for the new VCF Instance.

 

The VCF Installer should now allow the use of the desired DNS servers specific to the new VCF Instance.