Monitor failing after OPMS changes
search cancel

Monitor failing after OPMS changes

book

Article ID: 448698

calendar_today

Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction


We have observed that one of our monitors stopped working after changes in OPMS.

Monitor details:

Type : Full Page


OPMS Change:
sudo ./asm-installer update --set fpm.image.tag=25.10.7-prod --set fpm.image.name=debian13/asm-pop-fpm --purge -t <ID>

Error in Monitor: Unable to load page. 
Description:    9501: Does not match '/(Automatic sign in with Single Sign-On|Connexion automatique par authentification unique)/'

Resolution

The problem is on the application server. It returns html where it should return a json. The ew chrome browser is not tolerating this and won't load the page. Fix the application.

Monitoring a login page. 
If you get the page with curl and check the headers, you'll see something like that:

 

< x-content-type-options: nosniff 

which is a strict page protection against using files with invalid mime format.


 Try:
 

curl -v <url>

The response headers are (among others):
 

< HTTP/2 200 
< content-type: text/html
< content-length: 2589
< date: <date>
< last-modified: <date>
< etag: "<etag>"
< x-amz-server-side-encryption: AES256
< cache-control: public,max-age=0,must-revalidate,no-store,no-cache
< accept-ranges: bytes
...

and the content is really a html:
 

<!DOCTYPE html>
<html lang="en" translate="no">
  <head>
    <meta charset="utf-8"/>


This is the error message that explains it:
 
Failed to load module script: Expected a JavaScript-or-Wasm module script but the server responded with a MIME type of "text/html". Strict MIME type checking is enforced for module scripts per HTML spec.

 

For more information on the X-Content-Type-Options header, see this page:
https://developer.mozilla.org/en-US/docs/Web/HTTP/Reference/Headers/X-Content-Type-Options

Additional Information

Or switch the monitor to JMeter. it doesn't interpret JavaScript.