Task: Create and Commit draft check fails.Description: Verifies that the target image specification for the cluster is successfully created and committed.Result: Failed to invoke create and commit the desired state image spec.
YYYY-MM-DDTHH:MM:SS INFO vmware-vum-server <>[vc@4413 sub="com.vmware.vcIntegrity.lifecycle.ValidateDraftTask"] [ValidateDraftTask, 288] Task:com.vmware.vcIntegrity.lifecycle.ValidateDraftTask ID:<Task ID>. Draft validation succeeded, Notifications: { "errors": [ { "id": "com.vmware.vcIntegrity.lifecycle.EsxImage.SolutionNotFound", "message": { "args": [ "com.vmware.vsphere-wcp", "9.0.1.32.5.0-25065159", "", "" ], "default_message": "Software Solution com.vmware.vsphere-wcp with version 9.0.1.32.5.0-25065159 cannot be found in depot.",
[root@esx:~] localcli software vib list | grep -i sphereletspherelet 9.0.1.32.5.0-25065159 VMware VMwareCertified YYYY-MM-DD host
VCF 9.x
The issue is caused by an obsolete or inconsistent Workload Control Plane (WCP) offline depot remaining registered on the vCenter Server. This stale repository creates a metadata conflict that prevents vSphere Lifecycle Manager (vLCM) from correctly staging the WCP VIBs (Spherelet) for the target ESXi image.
Proceed to reload the WCP offline depot on vCenter
dcli com vmware esx settings depots offline listB0B9326BD84BA41BCE40538B89669E243D6C707E: owner: com.vmware.vcIntegrity file_id: /storage/updatemgr/patch-store-temp/vsphere-wcp-depot-embedded.zip description: WCP offline bundle ownerdata: com.vmware.vsphere-wcp location: source_type: PUSHdcli com vmware esx settings depots offline delete --depot <DEPOT_ID> --force trueSample:service-control --restart updatemgr && service-control --restart wcp
If the above steps do not resolve the issue, ensure the Supervisor Release Content Library is configured to "Download all library content immediately" and perform a manual synchronisation. If set to "Download library content only when needed", vLCM may fail to validate components because the binaries have not been pulled to the local vCenter storage, resulting in "Software Solution not found" errors.
After the change is made, you may need to follow the steps outlined in the KB again to resolve the issue.