Edge VM deletion/redeploy operation blocked from NSX UI
search cancel

Edge VM deletion/redeploy operation blocked from NSX UI

book

Article ID: 448623

calendar_today

Updated On:

Products

VMware NSX VMware Cloud Foundation

Issue/Introduction

  1. Edge VM delete operation can get stuck or blocked for the following reasons

    1. The connection between NSX Manager and vCenter is unstable.

    2. The original vCenter where the Edge VM was deployed has been unregistered, or the Edge VM has been vMotioned to a different vCenter.

    3. The VM cannot be deleted because the Destroy_Task and UnregisterVM  methods are disabled under Actions on the Edge VM in vCenter.

  2. During a rolling upgrade, redeploying an upgraded Edge node fails with: Ovf deploy for vm <name> failed on vc <ip> : VC operation failed : The name '<vm-name>' already exists.

  3. During a rolling upgrade, deleting an upgraded Edge node fails with: The method is disabled by 'com.vmware.nsx.management.nsxt'

Environment

VMware NSX 4.2.4

VMware Cloud Foundation 

Cause

Starting in NSX 4.2.4 / VCF 9.1, NSX deliberately disables the Destroy_Task and UnregisterVM methods on Edge VM  in vCenter, to prevent an Edge VM from being deleted or unregistered outside of NSX. If it were removed directly from vCenter, NSX would be left with a stale Edge VM reference on its side with no way to reconcile it. 

Resolution

This restriction can be lifted on the affected Edge VM to unblock the stuck operation, then retried.

  1. Log in to vCenter and locate the target Edge VM in the inventory.

  2. Select the Edge VM and make sure it is powered off, go to the Configure tab, then Disabled Methods.

  3. Select Destroy_Task and click Enable. Repeat this step for UnregisterVM." This re-enables "Remove from Inventory" and "Delete from Disk" for that VM.

  4. Retry the failed operation from NSX Manager (redeploy or delete Edge node).