VCHA configuration fails to deploy due to vSAN error "There are currently [X] usable fault domains. The operation requires [Y] more usable fault domains"
search cancel

VCHA configuration fails to deploy due to vSAN error "There are currently [X] usable fault domains. The operation requires [Y] more usable fault domains"

book

Article ID: 448587

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • VCHA configuration fails with status seen in GUI: 
    Status

    Cannot complete file creation operation.
    There are currently 4 usable fault domains. The operation requires 2 more usable fault domains.
    Failed to create object.
  • vpxd.log shows: 
    error vpxd[07007] [Originator@#### sub=Default opID=###] [VpxLRO] -- ERROR task-###--  -- Datacenters -- com.vmware.vcenter.vcha.cluster.
    deploy: :vim.fault.CannotCreateFile
    --> Result:
    --> (vim.fault.CannotCreateFile) {
    ..
    ..
    -->          message = "Failed to create object."
    -->       },
    ..
    ..
    -->          message = "There are currently X usable fault domains. The operation requires Y more usable fault domains."
    -->       }
    -->    ],
    -->    file = "xxxx - Upgraded-Passive (Cannot Create File)"
    -->    msg = "Cannot complete file creation operation."
  • VCHA is being deployed in a vSAN enabled cluster 

Environment

  • VMware vCenter Server 8.x
  • VMware vSAN (All versions)

Cause

  • The vSAN cluster does not have enough healthy, active fault domains to satisfy the Failures to Tolerate (FTT) rule defined in the assigned VM Storage Policy
  • In vSAN, a fault domain is typically an individual ESXi host, an explicitly defined group of hosts, or the vSAN Witness appliance

Resolution

Please follow the resolution steps outlined in KB 326856