During a VMware NSX upgrade (e.g., from 4.2.3.x to 4.2.4), the upgrade process exhibits one of the following behaviors:
Unable to start upgrade-coordinator upgrade. The version null is not recognized by the Manager./var/log/proton/nsxapi.log) contain entries: errorCode="MP30040" level="ERROR" subcomp="upgrade-coordinator" indicating Repository Sync status is not success.This issue occurs when the Upgrade Coordinator (UC) enters an indeterminate state due to a discrepancy between the management database and the physical files in the repository. Common triggers include:
/repository/ to resolve disk exhaustion.Follow these steps to restore the repository and proceed with the upgrade:
POST /api/v1/cluster/node?action=repo_syncNote: In NSX 9.1 and above, a prohibitive check prevents the re-upload of a PUB file of the same version specifically to prevent users from encountering this indeterminate database desync state.