File system specific implementation of Ioctl[file] failed Failed to start the virtual machine. Module Disk power on failed. Cannot open the disk '/vmfs/volumes/####/<VM-name>/####.vmdk' or one of the snapshot disks it depends on. The destination file system does not support large files'.
vmware.log shows unsupported disk capacity.In(05) worker-135917746 - DiskLibIsCapacitySupported: Unsupported disk capacity 21990232555520 bytes. Allowed disk capacity 17383785916071 bytes. Filename: /vmfs/volumes/####/####/####_1.vmdk.In(05) worker-135917742 - UTIL: Change file descriptor limit from soft 16384, hard 16384 to soft 16499, hard 16499.In(05) worker-135917746 - DISKLIB-VMFS : "/vmfs/volumes/####/####/####.vmdk" : closed.In(05) worker-135917746 - DISKLIB-LIB : Failed to open '/vmfs/volumes/####/####/####.vmdk' with flags 0xa The destination file system does not support large files (12).Er(02) worker-135917746 - DISK: Cannot open disk '/vmfs/volumes/####/####/####.vmdk': The destination file system does not support large files (12).VMware HCX
ESXi host DiskLib enforces a cached 16 TiB file size limit established during the initial NFS mount, even if Azure NetApp Files has been expanded to support larger files.
VMDK creation or expansion beyond 15.8 TB fails on NFS datastore
Refer to KB VMDK creation or expansion beyond 15.8 TB fails on NFS datastore for resolution steps.