VMware Aria Suite Lifecycle (formerly vRSLCM) services fail to start following a reboot due to a trustStoreInitialization error
search cancel

VMware Aria Suite Lifecycle (formerly vRSLCM) services fail to start following a reboot due to a trustStoreInitialization error

book

Article ID: 448338

calendar_today

Updated On:

Products

VMware vRealize Suite Lifecycle Manager 8.x

Issue/Introduction

- The vrlcm-server fails to start after appliance reboot

vrlcm-cli --health-status
bootstrap ------------- SUCCESS
postgres -------------  Running
vrlcm-server ------------- Not Running
blackstone ------------- Running

- Initial logs confirmed the vrlcm-server failed to run due to a Tomcat startup failure

Error starting Tomcat context

- Stack trace identified an initialization error specifically within the trustStoreInitalization bean

Error creating bean with name "trustStoreInitalization"

- Manual verification confirmed the /etc/alternatives/jre/lib/security/cacerts was inaccessible or broken:

java.io.EOFException

Environment

VMware vRealize Suite Lifecycle Manager 8.x

Resolution

1.Identify a healthy Aria Suite Lifecycle Manager instance at a different site or a backup.

keytool -list -keystore cacerts

2.SSH to the target Aria lifecycle manager appliance and back up the existing corrupted cacerts file on the affected instance.

cd /etc/alternatives/jre/lib/security

cp cacerts cacerts.bak

3.Copy the healthy cacerts file from the known good instance to the affected server:

cp <correct cacerts path> ./

4.Restart the vrlcm-server service if the service not start automatically.

systemctl restart vrlcm-server