esxcfg-vmknic -l shows TEP interfaces with an APIPA address (169.254.x.x) or 0.0.0.0.No valid v4 TEP IP for a long time of vmknic on VDS"VMware NSX
This issue occurs when the ESXi host's VMkernel interface fails to receive a DHCPOFFER from the DHCP server during the DORA process. This is typically caused by:
/var/log/dhclient.log for repeated discovery attempts without a response: dhclient-uw: DHCPDISCOVER on vmk10 to 255.255.255.255 port 67 interval 10 dhclient-uw: No DHCPOFFERS received.