HTTP Status 500 - Internal Server Error when launching Thin Client
search cancel

HTTP Status 500 - Internal Server Error when launching Thin Client

book

Article ID: 448204

calendar_today

Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

When Thin client or landing page is launched, error "HTTP Status 500 - Internal Server Error" is noticed after applying CA signed certificate. 

Environment

All Supported NCM environment. 

Cause

The CA-signed certificate was generated using a specific server name, but the client is connecting using a different name. This discrepancy causes a Server Name Indication (SNI) failure, resulting in the 500 error.

Resolution

  1. Login to NCM AS server with 'root' access.
  2. Navigate to $VOYENCE_HOME/bin/service and take backup of ncm-as and webtomcat service files. 
  3. In both service files's CATALINA_OPTS section add -Djdk.internal.httpclient.disableHostnameVerification=true Refer to screenshot:
  4. Restart vcmaster service. 
  5. Now client would launch as strict hostname verification is disabled.