The latency-sensitive virtual machine must have the CPU reservation set to at least 15594 MHz (the number of low latency virtual CPUs multiplied by the measured physical CPU speed). To disable this check, set latency.enforceCpuMin to FALSE in the virtual machine configuration.The error reported occurs because virtual machines with Latency Sensitivity set to High require a 100% CPU and memory reservation to power on or reconfigure.
During the VCDA failover to the destination vCenter, the VM is either losing its CPU reservation, the target Org VDC doesn't support the required reservation, or the destination hosts have a different CPU clock speed than the source hosts.
To resolve this issue, perform Step 1. from the Resolution of the following KB Article to set the Latency Sensitivity to Normal: