When attempting to unextend a network in VMware HCX, the task fails in the UI with the error: Network unextend failed
Review of the source HCX Manager log reveals:
2026-07-10 15:22:26.778 UTC [NetworkStretchService_SvcThread-69015, j: 76f8c977, s: 936f42be, , TxId: <UUID>] ERROR c.v.v.h.n.i.UnstretchNetworkJobInt- Remote site status is down. Use force option to un-stretch network locally.
Site pairing of the site shows certificate issue similar to:
VMware HCX 4.# / 9.#
The failure occurs because of a mismatch between the Remote HCX URL (configured as an IP address) and the Common Name (CN) or Subject Alternative Name (SAN) in the target HCX Manager’s SSL certificate (typically an FQDN).
To resolve this issue, follow the guide from HCX Site Pairing is 'disconnected' post certificate renewal on Target HCX Cloud