Tanzu Postgres smoke test fails with no such host error
search cancel

Tanzu Postgres smoke test fails with no such host error

book

Article ID: 448047

calendar_today

Updated On:

Products

VMware Tanzu Platform Data

Issue/Introduction

Smoke test errand fails with error like below

Stderr     Job (23c1d11f-xxx-xxx-xxx-xxxxxx) failed: bind could not be completed: Service broker error: POST https://193ba097-xxx-xxx-xxx-xxxxxxxx.postgres.service.internal:8443/create-binding failed with error Post https://193ba097-xxx-xxx-xxx-xxxxxxxx.postgres.service.internal:8443/create-binding: dial tcp: lookup 193ba097-xxx-xxx-xxx-xxxxxxxx.postgres.service.internal on 169.254.0.2:53: no such host

Environment

Tanzu Postgres. v10.4.1

Cause

This binding failure is the result of an uncommon race condition between the service adapter and the BOSH DNS health check cycle.

During a binding operation, the service adapter attempts to communicate with the postgres-agent to create a new database role. To do this, it makes an API call using the service instance's internal BOSH DNS hostname (e.g., instance-id.postgres.service.internal).

BOSH DNS operates on a polling interval and takes up to 5 seconds to re-check and mark a newly updated or provisioned service instance as "healthy." If the service adapter fires the /create-binding request during this narrow 5-second window before the BOSH DNS registry updates, the hostname resolution fails. Because the adapter cannot route the request to the postgres-agent, the entire binding operation fails.

Resolution

The resolution for this software defect is included in Tanzu Postgres v10.4.2