Users may observe intermittent failures where HTTP GET requests sent to a Virtual Service return a null or empty response.
Reviewing a packet capture (pcap) from the affected Virtual Service shows that a TLS Close Notify alert is sent back to the client immediately after the client transmits the HTTP GET request.
This issue specifically occurs on Virtual Services where an active DataScript is configured to process the request and return a response with a very small body payload to the client.
The issue can be resolved by disabling Client Insights on the Virtual Service.
Navigate to Applications > Virtual Services.
Locate the target Virtual Service and click the Edit icon (pencil tool) on the right side.
Select the Analytics tab at the top of the configuration page.
Scroll down to the Client Insights section.
Change the setting from Active to None (which sets it to NO_INSIGHTS).
Click Save to apply the changes.