免責事項:これは英文の記事「HTTP status 400 is returned with the error "The result set is too large. Please refine the search criteria" for Search API requests to NSX Manager from external sources.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
2026-07-02T22:11:32.511Z INFO http-nio-127.0.0.1-7440-exec-170 NsxBaseRestController 88645 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Error in API /nsxapi/api/v1/search/aggregate?cursor=60000 caused by exception com.vmware.nsx.management.search.querypipeline.exceptions.QueryPipelineException: {"moduleName":"nsx-search","errorCode":60576,"errorMessage":"Exception while searching during pipeline execution","details":"com.vmware.nsx.management.search.common.exceptions.SearchException: The result set is too large. Please refine the search criteria."}
VMware NSX
これは想定された仕様動作です。
Search API の実行結果に含まれるエントリ数が仕様上の上限を超過しています。
Search API の実行元で、より検索条件を絞り込んた API を実行してください。