外部から NSX Manager への Search API に対して、"The result set is too large. Please refine the search criteria" というエラーによって HTTP status 400 が返却されます。
search cancel

外部から NSX Manager への Search API に対して、"The result set is too large. Please refine the search criteria" というエラーによって HTTP status 400 が返却されます。

book

Article ID: 447947

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「HTTP status 400 is returned with the error "The result set is too large. Please refine the search criteria" for Search API requests to NSX Manager from external sources.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • Usage Meter やサードパーティのツールから NSX Manager に対する Search API に対して HTTP status 400 が返却されます。
  • NSX Manager の /var/log/proton/nsxapi.log には、下記のような "The result set is too large. Please refine the search criteria." を含むエラーが記録されています。

2026-07-02T22:11:32.511Z  INFO http-nio-127.0.0.1-7440-exec-170 NsxBaseRestController 88645 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Error in API /nsxapi/api/v1/search/aggregate?cursor=60000 caused by exception com.vmware.nsx.management.search.querypipeline.exceptions.QueryPipelineException:  {"moduleName":"nsx-search","errorCode":60576,"errorMessage":"Exception while searching during pipeline execution","details":"com.vmware.nsx.management.search.common.exceptions.SearchException: The result set is too large. Please refine the search criteria."}

Environment

VMware NSX

Cause

これは想定された仕様動作です。

Search API の実行結果に含まれるエントリ数が仕様上の上限を超過しています。

Resolution

Search API の実行元で、より検索条件を絞り込んた API を実行してください。