AD Users with a UPN suffix (e.g., <username>@<UPNsuffix>) fail to login to VCF Operations 9.1, however same users are successfully able to login to other Management components like SDDC Manager, vCenter. The VCF Operations UI displays the following error message: Failed to log in with VCF SSO service. The user did not import or does not belong to any imported group
vidb-external\vsp-####\vidb-service-####-####\vidb-service\console-log-####.logYYYY-MM-DDThh:mm:ss stdout F YYYY-MM-DDThh:mm:ss INFO accesscontrol 15 [vidb@4413 auditID="login" subject="<username>@<UPNsuffix>" object="####-####-####-####" origin="@component" result="success" baseType="Action" uuid="####-####-####-####" timestamp="####" tenantId="CUSTOMER" actorDomain="<DOMAIN>" actorUuid="####-#####-####-####" deviceId="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/149.0.0.0 Safari/537.36" value="{\"isForceAuth\":\"false\",\"tokenId\":\"####-####-####\",\"successAuthMethods\":\"EmbeddedIdp_####\",\"success\":\"true\",\"destination\":\"https://<VIDB_FQDN>/acs/t/CUSTOMER/authorize?response_type=code&client_id=####-####-####-####&redirect_uri=https%3A%2F%2F<VCF_OPS_FQDN>%2Fui%2FvidbClient%2Fvidb%2F&state=dmNmb3BzMS52Y2YubGFi\",\"authMethods\":\"LDAP\",\"actorExternalId\":\"####-####-####-####\"}" scPath="vidb/APPLIANCE"]YYYY-MM-DDThh:mm:ss stdout F YYYY-MM-DDThh:mm:ss INFO accesscontrol 15 [vidb@4413 threadName="vertx-generic-handler-pool-0" logger="com.vmware.vidm.accesscontrol.model.validator.RedirectUrlValidator" opId="####-####-####-####" tenantId="CUSTOMER" scPath="vidb/APPLIANCE"] [isValid] url : https://<VCF_OPS_FQDN>/ui/vidbClient/vidb/ , valid : trueActive Directory search attribute mappings from sAMAccountName to userPrincipalName.VCF Operations 9.1
This is a known issue with VCF Operations 9.1.0 will be resolved in a future release of VCF Operations. To workaround this, perform the following steps to remove the current IDP and configure the IDP afresh while ensuring the below steps:
Map the directory search attribute to userPrincipalName while configuring the LDAP bind.
During Attribute Mappings, map both userName and userPrincipalName to userPrincipalName.
Leave all other attribute mappings at their default values
To retrieve the vidb-service logs follow either of the below methods:
vcf-bundle-####-####_extracted\services-logs\vidb-external\vsp-####\vidb-service-####-####\vidb-service\console-log-####.logvmware-system-user
sudo -iif [ -f /etc/kubernetes/manifests/kube-apiserver.yaml ]; then echo -e "\n This is a CONTROL PLANE node"; else echo -e "\n This is a WORKER node"; echo " Control Plane Endpoint: $(sudo grep 'server:' /etc/kubernetes/kubelet.conf 2>/dev/null | awk -F'/' '{print $3}')"; fiexport KUBECONFIG=/etc/kubernetes/admin.confk get pods -A | grep -i vidbvidb-service pod name and check the logs for vidb-service container inside it:k logs -n vidb-external vidb-service-####-#### -c vidb-service |less