Deployments fail at Stage 15 in VMware Aria Suite Lifecycle 8.18.0 Patch 7 when deploying VMware Identity Manager
search cancel

Deployments fail at Stage 15 in VMware Aria Suite Lifecycle 8.18.0 Patch 7 when deploying VMware Identity Manager

book

Article ID: 447885

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Deployment of VMware Identity Manager (vIDM) global environment or a new clustered deployment in VMware Aria Suite Lifecycle 8.18.0 Patch 7, the task fails at stage 15 (Prepare pgpool).

Aria Suite Lifecycle (LCM) is unable to determine the vIDM version of the appliance during the deployment process in the user interface.

You observe the following error code and log message:

Error Code: LCMVIDM71406

Missing mandatory properties for Start/Stop VMware Identity Manager ElasticSearch or Opensearch service

Environment

  • VMware Aria Suite Lifecycle 8.18.0 Patch 7

  • VMware Identity Manager 3.3.7

Cause

This issue is caused by a compatibility requirement introduced in VMware Aria Suite Lifecycle 8.18.0 Patch 7. LCM Patch 7 requires specific configuration properties that are only present in vIDM appliances patched with CSP-102547 (or the cumulative equivalents). When you use an older vIDM OVA that does not have these CSP components pre-installed.

Resolution

To resolve this issue, you must use a vIDM OVA binary that is natively compatible with VMware Aria Suite Lifecycle 8.18.0 Patch 7.

  1. Download the VMware Identity Manager OVA version 3.3.7.0 Build 25163938 (or later) from the Broadcom Support Portal. This version contains the necessary CSP fixes required by LCM Patch 7.

  2. Map the new binary in Aria LCM:

    • In the VMware Aria Suite Lifecycle UI, navigate to Lifecycle Operations > Settings > Binary Mapping.

    • Select OVA Binary Mapping > Removed old Binary files

    • Click Add Binaries and provide the path to the newly downloaded OVA.

    • Click Discover and then Add to include it in the inventory.

  3. Redeploy the environment:

    • Delete the failed deployment environment from VMware Aria Suite Lifecycle.

    • Initiate the deployment again, ensuring that it's using newly mapped Build 25163938 OVA binary.

    • The deployment now successfully passes Stage 15, as LCM is able to identify the version and initialise the required services.

Additional Information