Attempts to connect VCF Operations to the Online Depot fail with a connectivity error during the authorization phase. The following error appears in the UI: Failed to connect to Broadcom OAuth Authorization server.
To verify the missing proxy configuration, review the download-service container logs within the Fleet Depot Service (FDS) pod on the VMware Cloud Foundation Management Services Provider (VMSP) by executing the following command:kubectl logs -n vcf-fleet-depot <pod-name> -c download-service returns a similar output:[FdsProxySettingsProviderImpl, ds-exec-3] Proxy configuration not presentException happened while processing the binary with id depotConfigcom.vmware.evo.sddc.common.core.error.InternalServerErrorException: Failed to connect to Broadcom OAuth Authorization ...OR
server Caused by: com.vmware.evo.sddc.lcm.depot_auth.exceptions.DepotAccessTokenIOException: java.net.UnknownHostException: eapi.broadcom.com: Temporary failure in name resolutionDepot Service configuration task has failed with error(s) Failed to connect to Broadcom OAuth Authorization server.. Please check connectivity to the server...
Proxy is configured for the VCF Operations:
VMware Cloud Foundation Operations 9.1
VMware Cloud Foundation Management Services Provider (VMSP) 9.1
The Fleet Depot Service (FDS) in VCF 9.1 does not inherit proxy settings from the VCF Operations global configuration. This causes the download-service container to lack an egress path, resulting in connection failures to Broadcom endpoints (such as but not limited to eapi.broadcom.com, dl.broadcom.com).
Follow either of the following methods to set up the proxy for VMSP: