VM deployment fails with Error: "Delegating token is not service token" in VMware Aria Automation
search cancel

VM deployment fails with Error: "Delegating token is not service token" in VMware Aria Automation

book

Article ID: 447841

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When attempting to deploy a virtual machine from VMware Aria Automation, the deployment fails during the post-provisioning phase.
The following extensibility error is displayed in the Aria Automation user interface:


Extensibility triggered task failed. Event ID: <Event ID>. Failure: Extensibility error received for topic compute.provision.post, eventld ='<Event ID>': SubscriberID: service-account-vro-gateway-serviceaccount, RunnableID:
<Workflow Runnable ID> and SubscriptionID: sub_<Subscription ID> failed with the following error: Workflow run [Workflow Run ID] completed with error [Delegating token is not service token.]

Additionally, the corresponding failed workflow run Logs in VMware Aria Automation Orchestrator, the following errors are observed:

Delegating token is not service token.
Unable to find VM by BIOS UUID :<VM UUID>, for SDK connection https://<vCenter FQDN>:443/sdk, reason : InternalErrorjava.lang.reflect. InvocationTargetException (Dynamic Script Module name :)
Unable to find VM by BIOS UUID :<VM UUID>, for SDK connection https://<vCenter FQDN>:443/sdk, reason : InternalErrorjava. lang.reflect.

Environment

VMware Aria Automation 8.18.x
VMware Aria Automation Orchestrator 8.18.x

Cause

The issue occurs because VMware Aria Automation Orchestrator is unable to establish a connection or receive a response from the vCenter Server.

Resolution

  • Verify the current health and status of the target vCenter Server endpoint.
  • Check if there are any active configuration changes, updates, or maintenance windows occurring on the vCenter Server.
  • Engage internal vCenter Server administration team to investigate the vCenter Server logs and restore stable SDK connectivity.
  • Once the vCenter Server is stable and fully operational, retry the virtual machine deployment from VMware Aria Automation.