Failure to model F5 BIG-IP devices as SNMP capable models
search cancel

Failure to model F5 BIG-IP devices as SNMP capable models

book

Article ID: 44784

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

I have set correct SNMP community string but using Discovery Console, Spectrum keeps model F5 BIG-IP device as pingable model, not SNMP capable model as expected. Clicking the [Contact] button on MIB Tools to contact the device shows green that indicates the device is contactable using the SNMP community string. However if I use MIB Tools to get sysObjectID (1.3.6.1.2.1.1.2) value from the device, it doesn't return any value (empty).

Environment

Release: Any
Component:

Cause

We specify OID for the top-most node of the SNMP tree in F5 BIG-IP device SNMP access configuration. This OID value should be at least 1.3.6.1 so that Spectrum can access both standard MIB-II and enterprise MIB data. The issue happens when this OID value is specified too restrictive so that Spectrum cannot access sysObjectID and other MIB-II OIDs that are required for SNMP modeling. 

Resolution

Configure the F5 BIG-IP device so that 1.3.6.1 is specified as OID for the top-most node of the SNMP tree and redo the discovery/modeling.