Register VC Site Workflow Fails With HttpHostConnectException Connection Refused error on Port 8043 in Aria Automation Orchestrator
search cancel

Register VC Site Workflow Fails With HttpHostConnectException Connection Refused error on Port 8043 in Aria Automation Orchestrator

book

Article ID: 447834

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In VMware Aria Automation Orchestrator (vRO), the "Register VC Site" workflow fails when attempting to register a remote vSphere Replication (vSR) site.

The following error is observed for this workflow in Orchestrator:

  • ERROR(com.vmware.library.vr/loginRemoteSite) Error in (Dynamic Script Module name : loginRemoteSite#1) https://<vSphere_Replication_FQDN>:8043 invocation failed with "org.apache.http.conn.HttpHostConnectException: Connect to <vSphere_Replication_FQDN>:8043 [<vSphere_Replication_FQDN>/<vSphere_Replication_IP>] failed: Connection refused"
  • ERRORWorkflow execution stack: *** item: 'Register VC Site/item2', state: 'failed', business state: 'null', exception: 'https://<vSphere_Replication_FQDN>:8043 invocation failed with "org.apache.http.conn.HttpHostConnectException: Connect to <vSphere_Replication_FQDN>:8043 [<vSphere_Replication_FQDN>/<vSphere_Replication_IP>] failed: Connection refused"

 

Environment

  • VMware Aria Orchestrator
  • VMware vSphere Replication
  • VMware Aria Automation Orchestrator Plug-In for vSphere Replication

Cause

The connection is refused because TCP port 8043 is not open from the Aria Automation Orchestrator appliance to the vSphere Replication site endpoints.

Resolution

  1. Open TCP port 8043 to allow management traffic between Aria Automation Orchestrator 8.x and the remote vSphere Replication site.
  2. Re-run the "Register VC Site" workflow to confirm successful communication.

Additional Information

KB 312798: Port numbers which must be open for vSphere Replication