In VMware Aria Automation Orchestrator (vRO), the "Register VC Site" workflow fails when attempting to register a remote vSphere Replication (vSR) site.
The following error is observed for this workflow in Orchestrator:
ERROR(com.vmware.library.vr/loginRemoteSite) Error in (Dynamic Script Module name : loginRemoteSite#1) https://<vSphere_Replication_FQDN>:8043 invocation failed with "org.apache.http.conn.HttpHostConnectException: Connect to <vSphere_Replication_FQDN>:8043 [<vSphere_Replication_FQDN>/<vSphere_Replication_IP>] failed: Connection refused"ERRORWorkflow execution stack: *** item: 'Register VC Site/item2', state: 'failed', business state: 'null', exception: 'https://<vSphere_Replication_FQDN>:8043 invocation failed with "org.apache.http.conn.HttpHostConnectException: Connect to <vSphere_Replication_FQDN>:8043 [<vSphere_Replication_FQDN>/<vSphere_Replication_IP>] failed: Connection refused"The connection is refused because TCP port 8043 is not open from the Aria Automation Orchestrator appliance to the vSphere Replication site endpoints.