2026-07-02T22:11:32.511Z INFO http-nio-127.0.0.1-7440-exec-170 NsxBaseRestController 88645 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Error in API /nsxapi/api/v1/search/aggregate?cursor=60000 caused by exception com.vmware.nsx.management.search.querypipeline.exceptions.QueryPipelineException: {"moduleName":"nsx-search","errorCode":60576,"errorMessage":"Exception while searching during pipeline execution","details":"com.vmware.nsx.management.search.common.exceptions.SearchException: The result set is too large. Please refine the search criteria."}VMware NSX
This is an expected behavior by design.
The number of entries contained in the execution results of the Search API exceeds the upper limit in the specifications.
At the source executing the Search API, execute the API with more refined search criteria.