HTTP status 400 is returned with the error "The result set is too large. Please refine the search criteria" for Search API requests to NSX Manager from external sources.
search cancel

HTTP status 400 is returned with the error "The result set is too large. Please refine the search criteria" for Search API requests to NSX Manager from external sources.

book

Article ID: 447817

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • HTTP status 400 is returned for Search API requests to NSX Manager from external sources such as Usage Meter or third-party tools.
  • In the /var/log/proton/nsxapi.log of NSX Manager, an error containing "The result set is too large. Please refine the search criteria." is recorded as follows:
2026-07-02T22:11:32.511Z  INFO http-nio-127.0.0.1-7440-exec-170 NsxBaseRestController 88645 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Error in API /nsxapi/api/v1/search/aggregate?cursor=60000 caused by exception com.vmware.nsx.management.search.querypipeline.exceptions.QueryPipelineException:  {"moduleName":"nsx-search","errorCode":60576,"errorMessage":"Exception while searching during pipeline execution","details":"com.vmware.nsx.management.search.common.exceptions.SearchException: The result set is too large. Please refine the search criteria."}

Environment

VMware NSX

Cause

This is an expected behavior by design.

The number of entries contained in the execution results of the Search API exceeds the upper limit in the specifications.

Resolution

At the source executing the Search API, execute the API with more refined search criteria.