Error: ERR_INVALID_RESPONSE when exporting reports - Web Viewer 14.0
search cancel

Error: ERR_INVALID_RESPONSE when exporting reports - Web Viewer 14.0

book

Article ID: 447810

calendar_today

Updated On:

Products

Output Management Web Viewer

Issue/Introduction

When attempting to use the export report option in Web Viewer 14.0, the browser returns the following error:

"This site Can't be reached
The webpage at http://###### might be temporarily down or it may have moved permanently to a new web address. 
ERR_INVALID_RESPONSE"

Environment

  • Output Management Web Viewer 14.0
  • CCS Apache Tomcat

Cause

The EXPORT_FORMAT OOXML creates a compressed file, which requires creating temporary directories and files in the location specified by the java.io.tmpdir directory.

The Tomcat started task user lacks write or directory creation (MKDIR) authority to this path.

The export request fails with:
CAHVS9000E Internal Server Error. HTTP status: 500 INTERNAL_SERVER_ERROR, Exception: java.lang.I
 llegalStateException, Error: java.nio.file.AccessDeniedException

Along with the following error from RACF:
ICH408I USER(SYSUSER ) - INSUFFICIENT AUTHORITY TO MKDIR

 

Resolution

Ensure the Tomcat started task user has sufficient permissions:

1. Give the Tomcat started task user (SYSUSER) read/write access to /###/tomcat10/temp directory 

Alternatively you can also:

2. Change the following line in CAHVCENV to point to a directory that the Tomcat started task user (SYSUSER) has read/write access.

IJO="$IJO -Djava.io.tmpdir=${CATALINA_BASE}/temp"

Additional Information

For more information regarding the CAHVS90000E see the [OM Web Viewer - Documentation] (https://techdocs.broadcom.com/us/en/ca-mainframe-software/traditional-management/web-viewer/14-0/messages/cahx-messages/cahvs9000e.html

To learn about ICH408I, see the [IBM ICH408I INSUFFICIENT AUTHORITY -  Documentation] (https://www.ibm.com/docs/en/zos/3.2.0?topic=rpm-ich408i-23) 

For further assistance with Tomcat deploy and configuration see the [Common Components and Services for z/OS - Deploy and Configure CCS Apache Tomcat - Documentation] (https://techdocs.broadcom.com/us/en/ca-mainframe-software/traditional-management/ca-common-services-for-z-os/15-0/installing/complete-configuration-tasks/deploy-and-configure-ccs-apache-tomcat.html)

For additional guidance with Tomcat security see the [Common Components and Services for z/OS - Configure Security for the CCS Apache Tomcat Region - Documentation] (https://techdocs.broadcom.com/us/en/ca-mainframe-software/traditional-management/ca-common-services-for-z-os/15-0/installing/complete-configuration-tasks/deploy-and-configure-ccs-apache-tomcat/deploy-ccs-apache-tomcat-and-configure-security.html#:~:text=the%20next%20section.-,Configure%20Security%20for%20the%20CCS%20Apache%20Tomcat%20Region,-After%20you%20deploy