Unable to configure Protection for VM in VCF Automation 9.1
search cancel

Unable to configure Protection for VM in VCF Automation 9.1

book

Article ID: 447807

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

  • When Protection and recovery service configured in VCF Automation and namespaces on the source and recovery site have been paired, as per Deploy and Configure Protection and Recovery for VCF Automation, Attempting to configure protection for VMs from VCF Automation 9.x organization between sites, remains stuck in "Configuring" state indefinitely. 
  • In the target recovery site, we do see creation of a recovery-VM, however, the following error pops up in the Tasks every 10 seconds:
    A generic error occurred in the vSphere Replication Management Server. Exception details: 'java.lang.RuntimeException: Operator message :'admission webhook "validate-quota-on-storagepolicyreservation.k8s.io" denied the request: Operation denied, StorageClass.storage.k8s.io "<storage_class_of_source_VM>" not found'; code :500'.  
  • Navigating to the target namespace in recovery site vCenter, lists the recovery-VM, also stuck in the "Configuring" state.
  • It could be validated that the source-VM on the source VCFA / VC is on a different storage class, than the target replica-VM.

Environment

  • VCF Automation 9.x

Cause

  • This is caused due to the absence of the storage class aligned to the source VM, on the recovery site. 
  • The Storage Class that is selected during creation of the VM on the source site must also exist on the recovery site vCenter. 

Resolution

  • Ensure that the the Storage Class that selected during creation of the VM on the source site must also exist on the recovery site vCenter, and that the selected storage class is compatible with the target datastore. Otherwise, replication will fail.
    For more details, refer Create a Protected VM

Additional Information

  • Note: 
    • Currently, once a VM is deployed from VCF Automation, there is no available method to change / migrate it to a different storage class. Redeployment of the VM onto the desired storage class (Ensuring compatibility of the storage class on the replication site) would be the only available method. Post which protection - recovery can be configured as expected.